Page 1 of 2 12 LastLast
Results 1 to 15 of 29
  1. #1
    5 Star Lounger
    Join Date
    Aug 2011
    Location
    South Africa
    Posts
    650
    Thanks
    67
    Thanked 2 Times in 2 Posts

    Slow restart W10.

    On windows 10 a restart takes about 6 minutes. I think this is too slow.
    Shut down is about 45 seconds, and startup about minute and half.

    Anything I can do to speed up restartup?

    Windows 10 1709 16299 371.

    Thanks

  2. #2
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,891
    Thanks
    29
    Thanked 439 Times in 348 Posts
    What hardware is Windows 10 running on?
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  3. #3
    5 Star Lounger
    Join Date
    Aug 2011
    Location
    South Africa
    Posts
    650
    Thanks
    67
    Thanked 2 Times in 2 Posts
    Running 32bit version.

  4. #4
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,891
    Thanks
    29
    Thanked 439 Times in 348 Posts
    Quote Originally Posted by DaveBRenn View Post
    Running 32bit version.
    Hardware - how much RAM, SSD or spinner hard drive, etc.
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  5. #5
    5 Star Lounger
    Join Date
    Aug 2011
    Location
    South Africa
    Posts
    650
    Thanks
    67
    Thanked 2 Times in 2 Posts
    Hope this is better.

    Hardware.png

  6. #6
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,891
    Thanks
    29
    Thanked 439 Times in 348 Posts
    Your specs are on the low end for Windows. You may well have too many unnecessary services/apps launching on startup. Trimming those unnecessary services/apps or setting them for delayed start in Services will help. In the search box type "startup" (without the quotes) and then select "See which processes start up automatically when you start Windows." You'll get a list of those processes. Snip that and post it here.
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  7. #7
    5 Star Lounger
    Join Date
    Aug 2011
    Location
    South Africa
    Posts
    650
    Thanks
    67
    Thanked 2 Times in 2 Posts
    Hi bbearren, the processes list is long, 34 Background processes and 33 Windows processes. Is this
    the list you need? If so, how would I copy the whole list without using about 5 print screens?
    Maybe I'm on the wrong track.
    Thanks

  8. #8
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Surrey, UK
    Posts
    237
    Thanks
    9
    Thanked 55 Times in 50 Posts
    Quote Originally Posted by DaveBRenn View Post
    Hi bbearren, the processes list is long, 34 Background processes and 33 Windows processes.
    That seems a lot - this is mine:
    startup.PNG
    and I intend to remove iTunes from that. Try sorting on start-up impact, and let us see the top ones. Note that my short list does not distinguish 'background' and 'windows' processes, which suggests you may be looking at a different list, but I can't tell which one (I can't find any tab which offers such a distinction).

    FWIW, my PC is only an Athlon X2-64 3800 with 2GB DDR2 memory, with a 1 TB HDD (not SSD) and it takes 45s to boot to the login screen, measured once the BIOS checks are done, so your times are slow. I am now going to see if any is shaved off that when iTunes has been disabled....

    ...makes no (significant) difference. A full restart takes almost exactly 60s, including the BIOS checks. The reason your shut-down + start-up times are much less than the restart total is probably because you have fast-start enabled (I don't) - when that is on, the shut-down is a form of hibernate, and the system state is saved to disk. Only the full restart guarantees that you start with a completely fresh state. It still shouldn't take 6 minutes.
    Last edited by mngerhold; 2018-04-23 at 07:16. Reason: Add full restart time

  9. #9
    5 Star Lounger
    Join Date
    Aug 2011
    Location
    South Africa
    Posts
    650
    Thanks
    67
    Thanked 2 Times in 2 Posts
    This is my list. I did look at Processes.

    startup.png

  10. #10
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Surrey, UK
    Posts
    237
    Thanks
    9
    Thanked 55 Times in 50 Posts
    Quote Originally Posted by DaveBRenn View Post
    This is my list. I did look at Processes.
    Duh! I always look at processes tab sorted by CPU or memory resource, so almost never see the split between Apps, Background and Windows processes that one gets when sorted by name. Silly me!

    That said, there's nothing you can disable under 'start-up' that you haven't already, the bulk of the stuff under processes will be windows, and while that can be tweaked, that's not the way to start. Does anything stand out as consuming a lot of cpu once started (sort processes on CPU)? That may provide a clue.

  11. #11
    5 Star Lounger
    Join Date
    Aug 2011
    Location
    South Africa
    Posts
    650
    Thanks
    67
    Thanked 2 Times in 2 Posts
    Martin, sorry about the delay in replying. Nothing seems to be consuming a lot of cpu.

  12. #12
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    24,179
    Thanks
    5
    Thanked 1,180 Times in 1,033 Posts
    Note that the default shutdown on Windows 10 is part of the fast startup feature. It does not perform a complete shutdown. That is most likely why it works quickly. On a restart a complete shutdown is performed before the reboot. I'm guessing that you mean the shut down part of the restart is taking a long time. This is usually because some component is not responding to the shutdown command in a timely manner. Often this is a networked drive, a mapped drive, or an external attached device.
    Joe

  13. #13
    5 Star Lounger
    Join Date
    Aug 2011
    Location
    South Africa
    Posts
    650
    Thanks
    67
    Thanked 2 Times in 2 Posts
    Joe, thanks for that explanation. What are networked and mapped drives and where would I check?
    What sort of external attached devices would I look for?
    Thanks.

  14. #14
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    24,179
    Thanks
    5
    Thanked 1,180 Times in 1,033 Posts
    If you access more than one PC on your network the other PC would be a networked device. A NAS (network attached storage) would be a network device. Mapping is a way to have a shortcut to a folder on a network device. An external device would most likely be something attached via USB. Could be a disk drive or dvd drive. If any of those device (network or external) are powered down and Windows tries to communicate the shutdown to them it will wait for a long time for a response.
    Joe

  15. #15
    Administrator Rick Corbett's Avatar
    Join Date
    Dec 2009
    Location
    South Glos., UK
    Posts
    3,140
    Thanks
    146
    Thanked 845 Times in 681 Posts
    You can adjust the shutdown delay using a .REG file.

    1. Copy/paste the following code into Notepad then save as Reduce_Shutdown_Time.reg.
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\Control Panel\Desktop]
    "HungAppTimeout"="1000"
    "WaitToKillAppTimeout"="2000"
    
    [HKEY_USERS\.DEFAULT\Control Panel\Desktop]
    "AutoEndTasks"="1"
    
    [HKEY_CURRENT_USER\Control Panel\Desktop]
    "AutoEndTasks"=-
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control]
    "WaitToKillServiceTimeout"="2000"
    2. Type regedit into Cortana's search box then, when regedit appears in the search results, right-click on it and choose Run as administrator.
    3. Accept the User Access Control (UAC) prompt then, when the Registry Editor opens, choose File > Import...
    4. Navigate to and select the .REG file you created in step 1.
    5. Once imported, click on the OK button to dismiss the confirmation dialog then close the Registry Editor.
    6. Restart for the change to take effect.

    Hope this helps...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •