Page 2 of 6 FirstFirst 1234 ... LastLast
Results 16 to 30 of 78
  1. #16
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,918
    Thanks
    517
    Thanked 465 Times in 434 Posts
    Very helpful, Rick. I always think in DOS whenever I'm in a Linux Terminal, so the command comparison is especially helpful.

    Now that I have Linux and Windows on two separate drives, and now that I must power down the computer to switch to the other OS, I am more motivated to learn Linux than I was originally. Previously, I had Linux in a VM, and it was easy to click back and forth, so I spent more time in Windows than in Linux.

  2. #17
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,918
    Thanks
    517
    Thanked 465 Times in 434 Posts
    Update: Try as I might, I have not been able to get my scanner working. Canon has no Linux driver on their website, so I had to hunt around for a driver. Fortunately, there is tons of information out there, easy to find, for Linux. I found excellent information about getting my specific scanner up and running (in network mode, not plugged directly into the computer) in Ubuntu Linux. But after about an hour of trying, I gave up on it for now.

    Another thing: I needed a Youtube video downloader. I found some add-ins for Firefox (one of them had very specific info about how to get the add in working for Ubuntu Linux), but I couldn't get any of them to work. But then I switched over to Windows and got two of them working immediately. Apparently there is a Windows component which won't install successfully in Linux.

    So I have discovered that there are tons of stuff out there for Windows, easy to install in Windows; but with Linux, you can't always find what you need; or, if you find it, in some cases you need to really know what you are doing to get it to work in Linux.

    On the positive side, the things which do work in Ubuntu Linux work very well. Everything is fast and very stable. For example, Libre Office, Firefox, Thunderbird, and various text editors come pre-installed with Ubuntu Linux, and they all work very well.

  3. #18
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,918
    Thanks
    517
    Thanked 465 Times in 434 Posts
    Update: I discovered an anomaly between Linux and Windows: Whenever I would boot into Linux, then exit Linux and boot into Windows, the time shown in Windows would be five hours off! I found that the cause of this is that Linux uses UTC (Universal Coordinated Time or Greenwich Mean Time) and converts from there to local time, whereas Windows uses local time. Consequently, every time I would go from Linux to Windows, I would see UTC rather than my local time.

    Here's how I fixed it: I did a registry edit in Windows.

    I went into the Windows registry and navigated to here:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\TimeZoneInformation

    I right-clicked in the right pane and selected New / DWORD (32-bit Value) -- "RealTimeIsUniversal" (without the quotes).

    I doubleclicked on RealTimeIsUniversal and changed the Value from 0 to 1.

    I rebooted into Linux, and then rebooted into Windows. Problem solved!

  4. The Following 3 Users Say Thank You to mrjimphelps For This Useful Post:

    bobprimak (2016-10-07),toextra (2016-10-04),wavy (2016-11-17)

  5. #19
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,571
    Thanks
    35
    Thanked 217 Times in 193 Posts
    That was a good catch for the dual-boot situation!
    BATcher

    Talking to laser printers can be very effective.
    You just need the right toner voice...

  6. The Following User Says Thank You to BATcher For This Useful Post:

    mrjimphelps (2016-10-01)

  7. #20
    WS Lounge VIP Browni's Avatar
    Join Date
    Dec 2009
    Location
    Rochdale, UK
    Posts
    1,752
    Thanks
    39
    Thanked 178 Times in 155 Posts
    How does Windows time/Linux time compare to the BIOS time now that you have changed one of them?

  8. #21
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,918
    Thanks
    517
    Thanked 465 Times in 434 Posts
    I went into the BIOS and found that the BIOS time was set to UTC, so I moved it back 5 hours (I'm in USA Central Time, UTC-5). I then went into Windows and found that the Windows time had been moved back 5 hours (Hawaii time?)! So I corrected the time in Windows, rebooted, and went back into BIOS. BIOS is now showing UTC time. So apparently the Windows and BIOS times are tied together, BIOS being on UTC and Windows converting that time to my local time. And since the BIOS time has never been off in this way, apparently my registry edit caused Windows to reset the BIOS time to UTC, and Windows then converts it from there to my local time.

    I rebooted a couple of times, going into Linux, BIOS, and Windows each a couple of times. Both Windows and Linux now show the correct local time, and the BIOS shows UTC time.

    The changes to the BIOS time didn't seem to have any affect on the time shown in Linux, so apparently Linux keeps track of its time in some way that is independent of the computer BIOS. Although, come to think of it, the Windows and BIOS time didn't get thrown off till I set up the dual boot with Linux; so Linux was definitely the original cause of the problem.

    I don't know if this has any impact on any of this, but my dual-boot situation is a bit different than others -- I have two separate hard drives, with a SATA power switch. So whenever I switch to the other OS, I first power down, then switch which drive is on / off, then power up. So the two OSs are on two separate drives, and they never have a chance to interact with each other in any way. Most dual boots are on the same drive, so there might possibly be a difference with mine.
    Last edited by mrjimphelps; 2016-10-01 at 13:47.

  9. #22
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,571
    Thanks
    35
    Thanked 217 Times in 193 Posts
    Linux uses Network Time Protocol (NTP), just like Windows does, but maybe the time offset was defaulted wrongly on your box, and needed changing?
    BATcher

    Talking to laser printers can be very effective.
    You just need the right toner voice...

  10. #23
    WS Lounge VIP Browni's Avatar
    Join Date
    Dec 2009
    Location
    Rochdale, UK
    Posts
    1,752
    Thanks
    39
    Thanked 178 Times in 155 Posts
    Thanks, I was wondering which one confused things!

    I don't think the dual boot setup will have any impact though.

  11. #24
    Lounger
    Join Date
    Oct 2013
    Posts
    36
    Thanks
    10
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by mrjimphelps View Post
    Update: I discovered an anomaly between Linux and Windows: Whenever I would boot into Linux, then exit Linux and boot into Windows, the time shown in Windows would be five hours off! I found that the cause of this is that Linux uses UTC (Universal Coordinated Time or Greenwich Mean Time) and converts from there to local time, whereas Windows uses local time. Consequently, every time I would go from Linux to Windows, I would see UTC rather than my local time.

    Here's how I fixed it: I did a registry edit in Windows.

    I went into the Windows registry and navigated to here:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\TimeZoneInformation

    I right-clicked in the right pane and selected New / DWORD (32-bit Value) -- "RealTimeIsUniversal" (without the quotes).

    I doubleclicked on RealTimeIsUniversal and changed the Value from 0 to 1.

    I rebooted into Linux, and then rebooted into Windows. Problem solved!
    Thank you for this explanation. I found the same time anomaly on my Win 7 laptop after booting Ubuntu from a USB thumb drive and then booting Win 7 from hdd.

  12. #25
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,918
    Thanks
    517
    Thanked 465 Times in 434 Posts
    I've decided that I will just live with my BIOS having UTC time, since both Windows and Linux now show the correct time. The main thing is that I now understand what the situation is, and so I can deal with it. I don't feel like again going through all of the reboots and registry edits that I had to go through to get to this point.

    It was very interesting discovering this. At first I thought a Windows update had perhaps thrown Windows into UTC; but the time change happened when I installed Linux, so that made perfect sense.

  13. #26
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,918
    Thanks
    517
    Thanked 465 Times in 434 Posts
    By the way, I have installed the new Brave browser in Linux. Brave (www.brave.com) was written by the guy who used to be the CEO of Mozilla. It was a very simple install, and it is a fast browser. I'll share my experience with the Brave browser in another post, so as not to distract from the topic of Linux in this post.

  14. #27
    New Lounger
    Join Date
    Dec 2009
    Location
    Gordonsville, VA
    Posts
    17
    Thanks
    4
    Thanked 2 Times in 2 Posts
    mrjimphelps, this is cool! I recently zapped Windows from my old laptop, with the intention of installing Ubuntu Linux (he-he).

    Currently, I am running it from a USB key, which I used during the zap phase. I will be following along and learning!

    Cheers,

    Mitch

  15. The Following User Says Thank You to Anklebuster For This Useful Post:

    mrjimphelps (2016-10-06)

  16. #28
    New Lounger
    Join Date
    Oct 2016
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Change Linux time, not Windows or BIOS

    Linux defaults to UTC, so that's what needs to be changed. It used to be you do this by changing the /etc/default/rcS file to read UTC=no. It may be different these days, but the principle is the same. Set Linux to local time. Might try "Linux UTC=no" as a Google term.

    And changing Linux time from a GUI screen won't work. It will only change your Windows time, too. Linux time needs to be changed in a configuration file, most likely from the command line.

  17. #29
    Lounge VIP bobprimak's Avatar
    Join Date
    Feb 2009
    Location
    Hinsdale, IL, USA
    Posts
    2,494
    Thanks
    177
    Thanked 157 Times in 131 Posts
    Quote Originally Posted by mrjimphelps View Post
    Update: I discovered an anomaly between Linux and Windows: Whenever I would boot into Linux, then exit Linux and boot into Windows, the time shown in Windows would be five hours off! I found that the cause of this is that Linux uses UTC (Universal Coordinated Time or Greenwich Mean Time) and converts from there to local time, whereas Windows uses local time. Consequently, every time I would go from Linux to Windows, I would see UTC rather than my local time.

    Here's how I fixed it: I did a registry edit in Windows.

    I went into the Windows registry and navigated to here:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\TimeZoneInformation

    I right-clicked in the right pane and selected New / DWORD (32-bit Value) -- "RealTimeIsUniversal" (without the quotes).

    I doubleclicked on RealTimeIsUniversal and changed the Value from 0 to 1.

    I rebooted into Linux, and then rebooted into Windows. Problem solved!
    My gosh!! That was what was happening in my Intel NUC when I installed a Ubuntu-Windows 10 Pro dual-boot. I had no idea it was an interaction between the OSes!

    Now the question is, do I need to fix the Windows Registry on a per-user basis (64-bits here) or is a single entry used for all users?
    -- Bob Primak --

  18. #30
    Lounge VIP bobprimak's Avatar
    Join Date
    Feb 2009
    Location
    Hinsdale, IL, USA
    Posts
    2,494
    Thanks
    177
    Thanked 157 Times in 131 Posts
    Quote Originally Posted by sathayer View Post
    Linux defaults to UTC, so that's what needs to be changed. It used to be you do this by changing the /etc/default/rcS file to read UTC=no. It may be different these days, but the principle is the same. Set Linux to local time. Might try "Linux UTC=no" as a Google term.

    And changing Linux time from a GUI screen won't work. It will only change your Windows time, too. Linux time needs to be changed in a configuration file, most likely from the command line.
    Which Ubuntu 16.04 LTS config file is this? I need to know because I do dual-boot and I do have the time-reset issue in Windows 10 Pro 64-bits.

    Otherwise, the Windows Registry Hack seems the best fix for now.

    Meanwhile, I copied the post to a file on my Windows Desktop for future application in all my Windows 10 Pro 64-bits installations.
    Last edited by bobprimak; 2016-10-07 at 04:32.
    -- Bob Primak --

Page 2 of 6 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •