Results 1 to 7 of 7
  1. #1
    WS Lounge VIP Lugh's Avatar
    Join Date
    Jun 2010
    Location
    Indy
    Posts
    1,363
    Thanks
    304
    Thanked 227 Times in 194 Posts

    "Raid on" to AHCI

    For some strange reason, the PC in my sig I 'inherited' recently shipped with "RAID on" set in UEFI, even tho it had only one disk. I've had fun with changing disks [I added 2 SSDs to the original HD, and changed boot to one of the SSDs] from MBR to GPT, and boot setup from BIOS to UEFI, followed by a day of "Automatic Repair" looping—these adventures detailed in other recent threads in this and the Win10 forum.

    During the run-arounds, I reset the setup to default, which includes "RAID on" as the disk config. I've never used RAID, but am familiar with it from reading over the years, and recall reading about RAID 0, RAID 1, RAID 5 etc, but not "RAID on".

    Doing some reading on it today, it seems to simply mean sth like "Turn RAID config on", rather than being a special flavor of RAID. Since I have no interest in a RAID config, I want to change back to AHCI for my 3 disks. I'm checking with you guys for guidance because setup popped up warning messages whenever I changed the setting earlier, to the effect of 'if you do this, you may not be able to boot or may have to reinstall OS'.

    My reading suggests that I need to:
    1. Make some registry changes to 're-enable' the AHCI driver;
    [these reg changes are detailed in Sangeeta Sarkar's reply on February 6, 2016 here]
    2. Then on reboot make the disk config change in UEFI.

    Do you guys agree with above plan?
    Lugh.
    ~
    Dell Alienware Aurora R6; Win10 Home x64 1803; Office 365 x32
    i7-7700; GeForce GTX 1060; 16GB DDR4 2400; 2 x 256G SSD, 4TB HD

  2. #2
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    9,073
    Thanks
    65
    Thanked 1,146 Times in 1,067 Posts
    How do you know you don't already have AHCI on?

    cheers, Paul

  3. #3
    WS Lounge VIP Lugh's Avatar
    Join Date
    Jun 2010
    Location
    Indy
    Posts
    1,363
    Thanks
    304
    Thanked 227 Times in 194 Posts
    Quote Originally Posted by Paul T View Post
    How do you know you don't already have AHCI on?
    In BIOS setup, there's a setting…
    Sata Operation
    …for which the choices are "RAID on" and "AHCI".
    It's currently set to "RAID on".
    Lugh.
    ~
    Dell Alienware Aurora R6; Win10 Home x64 1803; Office 365 x32
    i7-7700; GeForce GTX 1060; 16GB DDR4 2400; 2 x 256G SSD, 4TB HD

  4. #4
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    9,073
    Thanks
    65
    Thanked 1,146 Times in 1,067 Posts
    What happens when you change that to AHCI?

    Make an image backup before you do anything else so you can return to your current working system - I assume it's working?

    cheers, Paul

  5. #5
    WS Lounge VIP Lugh's Avatar
    Join Date
    Jun 2010
    Location
    Indy
    Posts
    1,363
    Thanks
    304
    Thanked 227 Times in 194 Posts
    Quote Originally Posted by Paul T View Post
    What happens when you change that to AHCI?
    Haven't tried that yet, was checking here first re the 2-step plan in my OP—ie reg changes before the AHCI change. Guess I'll go ahead with that shortly.

    your current working system - I assume it's working?
    Mostly. I'm experiencing occasional losses of my D: data drive—main pattern seems to be after the system goes to sleep or has been turned off. The C: and G: SSDs are working fine.

    I ran CHKDSK /f /r on D: and all went fine until the end, after ~2 hours, I ended up with CHKDSK failing with the message:
    "insufficient disk space to repair master file table (mft) mirror"
    Reading up on that has suggestions to delete some files to make room, which isn't my problem, I have over 800gig free on the 1TB D:. Others suggest it means the drive is bad or going bad. But maybe changing to AHCI will help, since I'm not convinced it's a 'real' error—it's only on the mirror of the MFT [there should still be an original MFT in place afaik], and the "insufficient disk space" reported is clearly wrong.

    The full CHKDSK report follows:
    Huh, scratch that, D: [where I saved the report] is gone again after another sleep session. CHKDSK had finished the earlier plus 2 long operations, checking used and free space, which I understand are the final checks before the last one on the MFT.

    Make an image backup
    Everything's backed up, image & data.
    Lugh.
    ~
    Dell Alienware Aurora R6; Win10 Home x64 1803; Office 365 x32
    i7-7700; GeForce GTX 1060; 16GB DDR4 2400; 2 x 256G SSD, 4TB HD

  6. #6
    WS Lounge VIP Lugh's Avatar
    Join Date
    Jun 2010
    Location
    Indy
    Posts
    1,363
    Thanks
    304
    Thanked 227 Times in 194 Posts
    Did the reg changes—only the two StartOveride keys needed changing from 3 to 0, the others were already set at 0.

    Rebooted, set Sata Operation to AHCI, and so far, so good after a further restart. D: is back, so here's the CHKDSK result from yesterday:

    C:\WINDOWS\system32>chkdsk D: /r /f
    The type of the file system is NTFS.
    Volume label is Data.

    Stage 1: Examining basic file system structure ...
    13568 file records processed.
    File verification completed.
    0 large file records processed.
    0 bad file records processed.

    Stage 2: Examining file name linkage ...
    14292 index entries processed.
    Index verification completed.
    0 unindexed files scanned.
    0 unindexed files recovered to lost and found.

    Stage 3: Examining security descriptors ...
    Security descriptor verification completed.
    362 data files processed.

    Stage 4: Looking for bad clusters in user file data ...
    Windows replaced bad clusters in file 2762
    of name \Pictures\BMP Archive\edited.bmp.
    13552 files processed.
    File data verification completed.

    Stage 5: Looking for bad, free clusters ...
    219488931 free clusters processed.
    Free space verification is complete.
    Correcting errors in the Master File Table (MFT) mirror.
    Insufficient disk space to repair master file table (MFT) mirror.
    CHKDSK aborted.
    An unspecified error occurred (6e74667363686b2e 1652).

    C:\WINDOWS\system32>

    As noted earlier, re "Insufficient disk space" error, there's over 800gig of this 1TB disk free.
    Lugh.
    ~
    Dell Alienware Aurora R6; Win10 Home x64 1803; Office 365 x32
    i7-7700; GeForce GTX 1060; 16GB DDR4 2400; 2 x 256G SSD, 4TB HD

  7. #7
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    9,073
    Thanks
    65
    Thanked 1,146 Times in 1,067 Posts
    I would suspect the hard disk. Run the manufacturers diags on it to see if it is behaving.

    cheers, Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •