Results 1 to 6 of 6
  1. #1
    Lounger
    Join Date
    Dec 2009
    Location
    Down Under
    Posts
    41
    Thanks
    7
    Thanked 0 Times in 0 Posts

    fixing internal ip address issues

    I am using a fixed "internal" ip address on our home network ( 192.168.xx) and have set this up via Network Connections/Internet Protocol Version 4 (TCP/Ipv4) and this has worked fine for years. Earlier today I lost network connection, then noticed an alert regarding an IP conflict and when checking my ip address via cmd ipconfig, I noticed the information was strange and completely different from all other pc on the network instead of 192.168.xxx it was - 169.254.231.237.

    Resetting the ip address via "obtain an IP address automatically" works though I would really like to fix this as I need to keep my ip address unchanged due to router settings for a VPN. I shutdown all pc at night and without a fixed setting, I may end up having a different allocation the next day. However if I try to set the ip address as fixed, I will lose internet connection again and doing ipconfig shows that it reverts back to the strange variation. What is causing this behaviour? A friend thinks it's malware but I would be very surprised - the pc is properly patched, I don't go to iffy sites, run AV, have most of my activity sandboxed and have not installed anything new the last few days. I did update the program version of my AV (NOD from V9 to V10) but did not notice any issues since then.

    Any suggestions or comments?

  2. #2
    2 Star Lounger Bender's Avatar
    Join Date
    Mar 2010
    Location
    Winston-Salem, NC USA
    Posts
    130
    Thanks
    17
    Thanked 17 Times in 16 Posts
    The 169.254 address is an APIPA address (Automatic private iP Address) which usually occurs when a pc cannot find a DHCP server. In your case using a fixed address means something else is stepping on it. It could be a faulty NIC card, firewall, Anti-Virus or who knows. Try booting in safe mode and see what happens. Is there anything else in your network that could be stepping on it, like a smart TV, Blu-Ray player, or any other Ethernet enabled appliance.

    With the suspect pc off try pinging (with another pc) for that address to see if anything answers.

    Another thing to check is to make sure the address is allocated in your router in the fixed addresses block. Other than that you might have to start disabling services one at a time, like the virus protection etc. to see if that has any affect on it.
    Do your part!!! Report SPAM to http://www.spamcop.net/

  3. #3
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    7,467
    Thanks
    181
    Thanked 984 Times in 936 Posts
    To avoid an IP address conflict when assigning a static IP address in a computer, you need to log into the router and see what the DHCP range is and then set the static IP address outside of that range.

    If your router uses the full range of 192.168.xxx.1 to 192.168.xxx.254 then you will need to decrease it to say .199 and then you can use any from .200 to .253

    .254 could be your Default Gateway, but you can check that by opening a command prompt and entering ipconfig /all

    The Default Gateway is what you use as an URL to log into your router.

    With the machine set to obtain auto, log into the router to see who else is connecting to your broadband if you don't have any other devices connected.

    As well as setting the static IP address in the computer, you can set it as a reserved IP address in the router.

    For that you will need the MAC code which is listed as the Physical Address in an ipconfig /all and when entering it in the router, separate the numbers with colons and not minus signs as it is displayed in the ipconfig /all

    With the IP address set to auto - we say DHCP enabled, in the ipconfig /all you can use the one that DHCP has assigned to it as the reserved IP address and then the router will not assign that to any other device.
    Last edited by Sudo; 2017-05-31 at 11:21.

  4. #4
    Lounger
    Join Date
    Dec 2009
    Location
    Down Under
    Posts
    41
    Thanks
    7
    Thanked 0 Times in 0 Posts
    thanks guys - I fixed the isssue before having the benefit of your comments, so I am not totally sure what did it. I think there was some DHCP issue as when the networking troubleshooter kicked in, that was fixed. I also suspect the smart TV may have been the one causing the conflict though I did not know at the time how to find out the ip address. In my pc I can run ipconfig but with printer and TV I am not sure, need to google on the pinging stuff. I disconnected wifi, then set my ip address again, rebooted and even this morning after a further complete reboot with wifi active, my ip address is as it should be.

  5. #5
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    7,467
    Thanks
    181
    Thanked 984 Times in 936 Posts
    Somewhere in the router it should have which devices are connected for the 24hr lease.

    It may be by name of the device or just by its MAC code.

    The printer and tv should have their MAC codes somewhere on them and you can compare theirs to both your wireless and Ethernet through an ipconfig /all.

    Don't know about the tv but you can assign a static IP address to the printer within the router as a fixed host, but both for the computer and printer, to avoid further conflicts you need to set those outside of the DHCP range.

  6. #6
    2 Star Lounger Bender's Avatar
    Join Date
    Mar 2010
    Location
    Winston-Salem, NC USA
    Posts
    130
    Thanks
    17
    Thanked 17 Times in 16 Posts
    Also, if you're using Win10 then you can look at the network via Windows Explorer and the TV will (should) show up under media devices. You can right click the various devices and the IP address will be in the network device properties
    Do your part!!! Report SPAM to http://www.spamcop.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •