Warning, though. It will overwrite your exiting 2.8x build, so the best option, for now (until the ops fix the co-exist issue; they had the same issue between 2.6 and 2.8 but finally addressed that) is to use a portable build. Below's some details about the new version of GIMP (and yes; supports high bit depth now).

https://www.gimp.org/news/2018/04/27...10-0-released/

There's 2 portable flavors in GIMP (I'm using samj's but I trust Partha's build too since I've had dealings with him for nearly a decade).

samj's build: http://gimpchat.com/viewtopic.php?f=7&t=16456
Partha's build: http://gimpchat.com/viewtopic.php?f=7&t=16455



Both builds have the latest G'MIC as I understand it. I can tell you that samj's build has both gtk and qt versions which is good since a few GIMP script-fus still use the gtk version. Now I have one heck of a learning curve since I've not tested the beta (2.9x builds). I then need to see what old plugins still with with this build of GIMP.