Results 1 to 1 of 1
  1. #1
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Polk County, Florida
    Thanked 516 Times in 404 Posts

    Learned Something New to Me - Again!

    As I mentioned in this post, I restored my Image for Windows partition images for my desktop to revert back to Windows 10 1803 because of the issues with 1809. I did the same for the dual boot on my desktop.

    I then used my TBWinRE USB drive to restore just the Windows 10 1803 OS partition from a full drive image of my laptop. That also went well. However, things got sticky when I tried to restore the 1803 drive image to the OS SSD in my NAS. I restored the most recent image from 10-3-2018, which was the day before 1809 was released, so I thought I would be golden. I was back to 1803 according to winver.exe, but when I started the sign-out, I got the option to "Upgrade and restart", and I hadn't had the NAS booted up long enough for much of anything to download. I checked Windows Update and found that 1809 was already downloaded and only needed a restart to begin installation.

    I opened a Command Prompt and typed in shutdown /r to hopefully avoid the preliminary installation that begins on sign-out, then booted my TBWinRE USB drive on the restart to restore an image from a week earlier, it failed on "files missing in boot loader" (or words to that effect) and then "file system corruption" almost immediately thereafter. I tried again with an earlier image, got the same errors. So I used the tools in the TBWinRE USB to open a Command Prompt and DISKPART, and my OS partition on the SSD drive was shown as "RAW". So I formatted it, and tried again. Same errors. Then I tried the 10-3-2018 image again, it restored, then booted up. But I still had the 1809 upgrade poised to start as soon as I signed out.

    I already knew from previous experience that Image for Windows will fail when it encounters bad sectors, and that running chkdsk /r will usually correct that situation and allow image creation. I also knew that it will fail a restore to a drive with bad sectors, which, again, can usually be corrected with chkdsk /r. Of course, that also means it's time to start shopping for a new drive. But I had not seen the two errors that I kept seeing today. Missing files, and file system corruption. That was puzzling, but I finally surmised that the pending upgrade flagged lots of files/folders with Windows specific markers for the upgrade process, and maybe that was the reason for the failure of the image restoration. Even using the command line "shutdown /r" didn't completely stop the upgrade process; stuff was happening in the background during the preparation for shutdown.

    Long story short (too late for that), I did another format, restored the 10-3-2018 image, but instead of rebooting, I plugged in my Media Creation Tool USB with 1803, and started a repair/reinstall. That proceeded normally, and without a hitch. So my NAS is now back to its pre-1809 condition, and I'm a happy camper.

    I can't help but think that the image of the OS partition that was prepped for the upgrade to 1809 had something to do with the whole shootin' match, but I'm not sure just what all was going on.
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  2. The Following 3 Users Say Thank You to bbearren For This Useful Post:

    RetiredGeek (2018-10-10),RockE (2018-10-09),satrow (2018-10-09)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts